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Editorial Record 
Manual 

Version no. Date edited Page Content 

1.00 October 2008  Original 

1.01 January 2009 5 Explanations about supported device and OS are revised in 
Table 1.1 in Chapter 1. 

1.02 March 2011 5 Explanations about supported device and OS are revised in 
Table 1.1 in Chapter 1. 
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Preface 
This reference manual explains how to configure the server environment for the CASIO VoIP 
Software (“CVS”). 
 
The CASIO VoIP Software (“CVS”) consists of the following software. 
 

Software Device/Terminal 
HT Client HT Client 
CVS Server CVS Server PC 
PC Client PC Client (PC) 

 
The word of “CVS Client” used in this manual refers to both HT Client terminal and PC Client 
(PC). 
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1. System Configuration 
This chapter explains the system configuration of VoIP using the CASIO VoIP Software 
(“CVS”) (see Figure 1.1) and software to install in each device/terminal, and supported devices and 
Oss. See Table 1.1. 
 

 
Figure 1.1 
 
Table 1.1 

Name Supported Device and OS Software to 
install 

 

 

HT Client Device: DT-X7, DT-X8, IT-300, IT-800(CE) 
 
OS: 
- Windows CE 5.0 
- Windows CE 6.0 
- Windows Mobile 6.5 Classic 

HT Client  

 

PC Client Device: PC (IBM compatible) 
OS:  
- Windows 2000 Professional SP4 
- Windows XP Professional 
- Windows Vista Business 

PC Client 
(None) 
 

 

 

CVS Server Device: PC (IBM compatible) 
OS:  
- Windows 2000 Server SP4 which supports IIS 5.0 
- Windows Server 2003 Standard Edition which 

supports IIS 6.0 

CVS Server  

  

  

  

PC Client 
in PC 

HT Client 

CVS Server in 
Server PC 
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2. Installing Internet Information Services 
Make sure that an Internet Information Services (“IIS”) (in case of Windows Server 2003) 
environment has been set effect in the PC by navigating to the icons below. If not, follow the 
explanation in Chapter 2.1 for Windows 2000 Server or in Chapter 2.2 for Windows Server 2003. 
 
• In case of Windows 2000 Server 

Navigate to Control Panel → Administrative Tools → Internet Information Services. 
 
• In case of Windows Server 2003 

Navigate to Control Panel → Administrative Tools → Internet Information Services. 
 
 

2.1 Installation Procedure for Windows 2000 Server 
If your PC runs in the Windows 2000 Server, follow the steps below to set the Internet Information 
Services effect. 

 
1. Log in as "Administrator". 
2. From the Start menu, navigate to Control Panel → Add or Remove Programs and choose 

Add/Remove Windows Components. 
3. Double click Application Server and check Internet Information Services [IIS]. See 

Figure 2.1. 

 
Figure 2.1 
 
4. Insert the Microsoft Windows 2000 Server CD and click OK button. 
5. Reboot the system once the installation is complete. 



 

2.2 Installation Procedure for Windows Server 2003 
If your PC runs in the Windows Server 2003, follow the steps below to set the Internet Information 
Services effect. 
 
1. Log in as "Administrator". 
2. From the Start menu, navigate to Control Panel → Add or Remove Programs and choose 

Add/Remove Windows Components. 
3. Double click Application Server and set all three boxes effect. See Figure 2.2. 

• ASP.NET 
• Enable network COM+ access 
• Internet Information Services [IIS] 

 

 
Figure 2.2 

 
4. Insert the Microsoft Windows XP or Windows 2003 Server Enterprise Edition CD and click OK 

button. 
5. Reboot the system once the installation is complete.  
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3. Setting Configuration for CVS Server 
This chapter explains how to configure the system for the CVS Server. 
 
 

3.1 Setting Web Application Publication 
1. Navigate to Control Panel → Administrative Tools → Internet Information Services 

[IIS] Manager (or Internet Service Manager for Windows 2000 Server). 
2. Right click Default Web Site and then navigate to New → Virtual Directory …. See Figure 

3.1. 

 
Figure 3.1 



 
3. Follow the Wizard screen prompts to carry out the rest of the settings. 

 
Figure 3.2 
 
4. Click Next > button (see Figure 3.2) to open the Virtual Directory Creation Wizard. 
5. Type in "CVSSERVER" in the Alias field. 

 
Figure 3.3 
 
6. Click Next > button in Figure 3.3 so that the Web Site Content Directory screen appears. See 

Figure 3.4. 
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7. Click Browse … button in Figure 3.4 and then choose “C:\Program Files\CASIO\MVC\HTML” 

in the Path field. 

 
Figure 3.4 
 
8. Confirm that the path set in Figure 3.4 appears in the Directory field in Figure 3.5 and then click 

Next > button. 

 
Figure 3.5 



 
9. Set Read and Run scripts [such as ASP] effect and then click Next > button. See Figure 

3.6. 

 
Figure 3.6 
 

10. The screen in Figure 3.7 appears. To close the screen, click Finish button. 

 
Figure 3.7 
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3.2 Setting the State Service to Start 
1. Navigate to Control Panel → Administrative Tools → Services (Local) and double click 

ASP.NET State Service. 

 
Figure 3.8 
 
2. In General tab of ASP.NET State Service Properties (Local Computer), highlight Automatic in 

Startup type field, and then click Start button followed by OK button. See Figure 3.9. 

  

Figure 3.9 



 

3.3 Configuring Data Folder 
1. Launch Explorer and then navigate to Tools → Folder Options. 
2. In View tab, set Show hidden files and folders of the Hidden files and folders icon effect 

and then click OK button. 

 
Figure 3.10 
 
3. Now navigate to C:\Documents and Settings\All Users\Application Data and create a new folder 

named "CASIO". 
4. In this new “CASIO” folder, create a new folder named "CVS". 
5. Copy all the folders and files under path of “C:\Program Files\CASIO\MVC\SAMPLE” to under 

the path of this new folder. 
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3.4 Setting Data Folder Access Authority 
1. Launch Explorer and then navigate to the “C:\Documents and Settings\All Users\Application 

Data\CASIO” folder. 
2. Right click this folder and choose Properties. See Figure 3.11. 
3. The CASIO Properties screen appears. See Figure 3.12. 

 

Figure 3.11 
 
4. In the CASIO Properties screen, click Security tab and then Add … button. 

 
Figure 3.12 



 
5. Highlight ASPNET (see Figure 3.13) and then click Add button. 

 
Figure 3.13 
 
6. Confirm that “ASPNET” has been added, and then click OK button. 

 
Figure 3.14 
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7. In Security tab, highlight ASP.NET Machine Account [machine number] in the Name field. 

Set Full Control in the Permissions field to Allow and then click OK button. 

 
Figure 3.15 
 
8. Repeat the step no. 7 for each of the following folders and files to permit full control access by 

ASP.NET Machine Account [machine number]. 
 

• Folders 
[DATAROOT]\CVS 
[DATAROOT]\CVS\DATA 
[DATAROOT]\CVS\DATA\VOICE 
[DATAROOT]\CVS\USERS 

• Files 
[DATAROOT]\CVS\CVSConfig.xml 
[DATAROOT]\CVS\DATA\CVSAddressBook.xml 
[DATAROOT]\CVS\DATA\CVSGroup.xml 
[DATAROOT]\CVS\DATA\CVSGroupUser.xml 

 
[DATAROOT] = C:\Documents and Settings\All Users\Application Data\CASIO 



 

3.5 Setting the CVS Client Functions 
This chapter explains how to set up the CVS Client functions. Follow the procedure below. 

 
1. Launch Internet Explorer and open a web page with the following URL. 
 

http://(CVS Server Name)/CVSServer/CVSServerConfig/Default.aspx 
 
2. Enter the following account details in the login screen. 
 

Login name : CVSADMIN 
Password : CASIO 

 
The above login name and password are defined in the following file. The Internet Information 
Services [IIS] must be rebooted to change these account details. 

 
[Document and Setting]\All Users\Application Data\Casio\CVS\CVSAdminUser.xml 

 
3. When the login is complete, the screen appears. See Table 3.1 for the roles of each basic function 

nos. 1 to 18 in Figure 3.16. 

1

2

3

4

5
6
7
8
9
10

11
12
13
14

15

18

16
17

19

 
Figure 3.16 
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Basic Functions 
Table 3.1 

Parameter Description 
(1) Public history entries - Designates the history retained number in the range of 10 to 1000 for 

sent out messages in the batch mode.  
- Any change to this parameter if made is reflected immediately after 

the setting. 
- If a number outside of the range is specified, the "Error: public history 

entries value is incorrect" error message appears in the error display 
area. 

(2) Private history entries - Designates the history retained number in the range of 10 to 50 for 
sent out/received messages by private. 

- Any change to this parameter if made is reflected immediately after 
the setting. 

- If a number outside of the range is specified, the "Error: private 
history entries value is incorrect" message appears in the error display 
area. 

(3) Maximum recording time - Designates a period of the recording time in the range of 5 to 30 
seconds for voice message. 

- If a number outside of the range is specified, the "Error: maximum 
recording time value is incorrect" message appears in the error display 
area. 

(4) Keep-alive statement time - Designates a period of interval time in the range of 0 to 3600 seconds 
for sending keep-alive statement to the CVS server. No statement is 
sent if 0 is set for the parameter. 

- Any change to this parameter if made is reflected at subsequent login 
on the CVS Client. 

- If a number outside of the range is specified, the "Error: keep-alive 
statement time value is incorrect" message appears in the error display 
area. 

(5) Text messaging - Enables the text send out function. 
- Any change to this parameter if made is reflected at subsequent login 

on the CVS Client. 
(6) Silent mode - Enables the silent mode function. If this function is set disabled, the 

CVS Client hides the silent mode button in the standby screen. 
- Any change to this parameter if made is reflected at subsequent login 

on the CVS Client. 
(7) Call screening - Enables the call screening function. If this function is set disabled, the 

CVS Client hides the call screening button in the standby screen. 
- Any change to this parameter if made is reflected at subsequent login 

on the CVS Client. 
(8) Settings - Enables the settings button.  

- This function is not supported by the current version. 
(9) Log off - Enables the log off function. 

- Any change to this parameter if made is reflected at subsequent login 
on the CVS Client. 

(10) DTMF - Enables the DTMF function. 
- Any change to this parameter if made is reflected at subsequent login 

on the CVS Client. 
(11) Dialed calls - Enables the dialed call function. 

- Any change to this parameter if made is reflected at subsequent login 
on the CVS Client. 

(12) Presence - Enables the presence function.  
- This function is not supported by the current version. 

(13) Auto call receive - Picks up incoming calls automatically. 
- Any change to this parameter if made is reflected at subsequent login 

on the CVS Client. 
Continue. 



 
(14) Voice message auto 

playback 
- Plays back received voice message automatically. 
- Any change to this parameter if made is reflected at subsequent login on 

the CVS Client. 
(15) Voice message auto close - Closes the user operation dialog box automatically after the voice 

message is played back. 
- Any change to this parameter if made is reflected at subsequent login on 

the CVS Client. 
(16) Confirm log off  - Displays the log off confirmation dialog at a time of log off. 

- Any change to this parameter if made is reflected at subsequent login on 
the CVS Client. 

(17) Confirm close - Displays the close confirmation dialog box when an application is 
terminated. 

(18) Link work - Hides the main window when the user operation dialog box is displayed 
upon sending/receiving etc. 

- Any change to this parameter if made is reflected at subsequent login on 
the CVS. 

(19) Error display area - An error message in red appears when a value outside of the range is 
specified.  

 

4. Set the CVS Client functions and click Set button at the very bottom of the page.  

 19



 

 

 

20

 

4. CVS Server Configuration Files 

4.1 Phone Address Book ("Contacts") 
This feature collectively manages all information on the CVS System users.  
 
 

4.1.1 

4.1.2 

File Path 
Public address book:  
\CVS\DATA\CVSAddressBook.xml 
 
Private address book:  
\CVS\USERS\[USERID]\CVSPrivateAddressBook.xml 
 
 

Format 
The public and private address books are configured in the same format which is described below. 
 
<?xml version="1.0" encoding = "UTF-8" standalone="yes"?> 

<NewDataSet> 

  <USERDATA> 

    <USERID>[USER ID]</USERID> 

    <USERNAME>[USER NAME]</USERNAME> 

    <NAMEREAD>[PHONETIC READING]</NAMEREAD> 

    <PASSWD>[PASSWORD]</PASSWD> 

    <SIPUSERID>[SIPID]</SIPUSERID> 

    <SIPPASSWD>[SIP PASSWORD]</SIPPASSWD> 

    <SIPURI>[SIP ADDRESS]</SIPURI> 

    <PRESENCE>[PRESENCE FLAG]</PRESENCE> 

    <PRESENCE>[ADDITIONAL INFO]</REMARKS> 

    <ACTIVITY>[VALIDITY]</ACTIVITY> 

  </USERDATA> 

</NewDataSet> 



Configuration of the Public/Private Address Books 
 
Table 4.1 

Parameter Description Setting range 
[USER ID] - ID which is unique for each user. 32 characters or less 
[USER NAME] - User name displayed in the address book. 64 characters or less 

[PHONETIC 
READING] 

- Phonetic reading of the user name. 
- Sorting is performed based on this information. 

64 characters or less 

[PASSWORD] - Password which corresponds to the user ID. 
- The user authentication web service determines the 

validity using submitted user ID and this password. 

32 characters or less 

[SIPID] - Unique ID attributed to each user which is used for 
SIP server registration. 

64 characters or less 

[SIP PASSWORD] - Password corresponding to the SIP ID.  64 characters or less 
[SIP ADDRESS] - User's SIP address which is defined with SIP scheme. 

 
Example: 
SIP:129.1.52.46,SIP: member1@casio.co.jp etc. 

64 characters or less 

[PRESENCE FLAG] - User’s presence status Undefined 

[ADDITIONAL] 
O]

- Additional information on the user Undefined 
[VALIDITY] - Validity of the above-mentioned information.  0: Invalid  

1: Valid 
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Example of Public/Private Address Books Configuration 
<?xml version="1.0" encoding = "UTF-8" standalone="yes"?> 

 

<NewDataSet> 

  <USERDATA> 

    <USERID>00001</USERID> 

    <USERNAME>MEMBER 1</USERNAME> 

    <NAMEREAD>MEMBER 1</NAMEREAD> 

    <PASSWD>no00001</PASSWD> 

    <SIPUSERID>00001</SIPUSERID> 

    <SIPPASSWD>no00001</SIPPASSWD> 

    <SIPURI>sip:129.1.52.46</SIPURI> 

    <PRESENCE>0</PRESENCE> 

    <REMARKS /> 

    <ACTIVITY>1</ACTIVITY> 

  </USERDATA> 

  <USERDATA> 

    <USERID>00002</USERID> 

    <USERNAME>MEMBER 2 </USERNAME> 

    <NAMEREAD>MEMBER 2</NAMEREAD> 

    <PASSWD>no00002</PASSWD> 

    <SIPUSERID>00002</SIPUSERID> 

    <SIPPASSWD>no00002</SIPPASSWD> 

    <SIPURI>sip:129.1.51.121</SIPURI> 

    <PRESENCE>0</PRESENCE> 

    <REMARKS /> 

    <ACTIVITY>1</ACTIVITY> 

  </USERDATA> 

  <USERDATA> 

    <USERID>00003</USERID> 

    <USERNAME>MEMBER 3</USERNAME> 

    <NAMEREAD>MEMBER 3</NAMEREAD> 

    <PASSWD>no00003</PASSWD> 

    <SIPUSERID>00003</SIPUSERID> 

    <SIPPASSWD>no00003</SIPPASSWD> 

    <SIPURI>sip:member3@casio.co.jp</SIPURI> 

    <PRESENCE>0</PRESENCE> 

    <REMARKS /> 

    <ACTIVITY>1</ACTIVITY> 

  </USERDATA> 

  </NewDataSet> 
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4.2 Group Configuration 
This configuration collectively manages all the groups. 
 
 

4.2.1 

4.2.2 

File Path 
\CVS\DATA\CVSGroup.xml 
 
 

Format 
The following shows the group configuration file format. 
<?xml version="1.0" encoding = "UTF-8" standalone="yes"?> 

<NewDataSet> 

  <GROUPDATA> 

    <GROUPID>[GROUP ID]</GROUPID> 

    <GROUPNAME>[GROUP NAME]</GROUPNAME> 

  </GROUPDATA> 

</NewDataSet> 

 
Table 4.2 describes the group configuration parameters. 
Table 4.2 

Parameter Description Setting range 
[GROUP ID] ID which is unique for each group. 32 characters or less 
[GROUP NAME] Group name displayed in the address book. 64 characters or less 

 
Example of Group Configuration 
<?xml version="1.0" encoding = "UTF-8" standalone="yes"?> 

<NewDataSet> 

  <GROUPDATA> 

    <GROUPID>000001</GROUPID> 

    <GROUPNAME>GROUP １</GROUPNAME> 
  </GROUPDATA> 

  <GROUPDATA> 

    <GROUPID>000002</GROUPID> 

    <GROUPNAME>GROUP 2</GROUPNAME> 

  </GROUPDATA> 

  <GROUPDATA> 

    <GROUPID>000003</GROUPID> 

    <GROUPNAME>GROUP 3</GROUPNAME> 

  </GROUPDATA> 

  <GROUPDATA> 

    <GROUPID>000004</GROUPID> 

    <GROUPNAME>GROUP 4</GROUPNAME> 

  </GROUPDATA> 

</NewDataSet> 
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4.3 Group Member Configuration 
This configuration collectively manages the list of all users who belong to the group. 
 
 

4.3.1 

4.3.2 

File Path 
\CVS\DATA\CVSGroupUser.xml 
 
 

Format 
The following shows the format of the group member configuration file. 
<?xml version="1.0" encoding = "UTF-8" standalone="yes"?> 

<NewDataSet> 

  <GROUPUSERDATA> 

    <GROUPID>[GROUP ID]</GROUPID> 

    <USERID>[USER ID]</USERID> 

    <ACTIVITY>[VALIDITY]</ACTIVITY> 

  </GROUPUSERDATA> 

</NewDataSet> 

 
Table 4.3 describes the group member configuration parameters. 
Table 4.3 

Parameter Description Setting range 
[GROUP ID] ID which is unique for each group. 32 characters or less 
[USER ID] ID which is unique for each user. 32 characters or less 
[VALIDITY] Validity of the above-mentioned information.  

 
0: Invalid  
1: Valid 



 
Example of Group Member Configuration 
<?xml version="1.0" encoding = "UTF-8" standalone="yes"?> 

<NewDataSet> 

  <GROUPUSERDATA> 

    <GROUPID>000001</GROUPID> 

    <USERID>no00001</USERID> 

    <ACTIVITY>1</ACTIVITY> 

  </GROUPUSERDATA> 

  <GROUPUSERDATA> 

    <GROUPID>000001</GROUPID> 

    <USERID>no00002</USERID> 

    <ACTIVITY>1</ACTIVITY> 

  </GROUPUSERDATA> 

  <GROUPUSERDATA> 

    <GROUPID>000001</GROUPID> 

    <USERID>no00003</USERID> 

    <ACTIVITY>1</ACTIVITY> 

  </GROUPUSERDATA> 

</NewDataSet> 
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4.4 Setting CVS Server Operations 
This chapter describes how to set up the data and functions managed by the CVS Server. 
 
 

4.4.1 

4.4.2 

File Path 
\CVS\CVSConfig.xml 
 
 

Format 
The following shows the format the configuration file. 
<?xml version="1.0" encoding = "UTF-8" standalone="yes"?> 

<NewDataSet> 

  <MVCCONFIG>  

    <PRIVATEHISTORYNUM>[NO. OF PRIVATE HISTORY 

ENTRIES]</PRIVATEHISTORYNUM> 

    <PUBLICHISTORYNUM>[NO. OF PUBLIC HISTORY 

ENTRIES]</PUBLICHISTORYNUM> 

    <PRIVATEADDRESSBOOK>[PERMIT PRIVATE ADDRESS BOOK 

USE]</PRIVATEADDRESSBOOK> 

  </MVCCONFIG> 

</NewDataSet> 

 
Table 4.4 describes the parameters of the CVS Server operation configuration file. 
Table 4.4 

Parameter Description Setting range 
[NO. OF PRIVATE 
HISTORY ENTRIES] 

Maximum number of private entries in the sent/received 
history folder ("Recent" tab in the GUI) 

10 to 50 

[NO. OF PUBLIC 
HISTORY ENTRIES] 

Maximum number of entries saved in the public voice 
message history folder 

10 to 1000 

[PERMIT PRIVATE 
ADDRESS BOOK USE] 

Determines the use of the private address book. 0: Do not use 
1: Use 

 
Example of the CVS Server Operation Configuration File 
<?xml version="1.0" encoding = "UTF-8" standalone="yes"?> 

<NewDataSet> 

  <MVCCONFIG> 

    <PRIVATEHISTORYNUM>30</PRIVATEHISTORYNUM> 

    <PUBLICHISTORYNUM>1000</PUBLICHISTORYNUM> 

    <PRIVATEADDRESSBOOK>0</PRIVATEADDRESSBOOK> 

  </MVCCONFIG> 

</NewDataSet>  



5. Setting CVS Client 
This chapter describes the setting required on the CVS Client to access the CVS Server. 
In the folder where the CVS Client is installed, the CVSClient.ini configuration file resides. In this 
configuration file, remove the line header comment specified in the below file. 
 
[MVCSERVICE] 

server=[CVS Server name or IP address] 

Regist=/MVCSERVER/MVCUserRegistService/UserRegistService.asmx 

 ← Remove the line header comment. 
History=/MVCSERVER/MVCHistoryRecordService/HistoryRecordService.asm

x ←    〃 

Text=/MVCSERVER/MVCIMVoiceService/IMVoiceService.asmx ←  〃 

Voice=/MVCSERVER/MVCIMVoiceService/IMVoiceService.asmx ←  〃 
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6. Changing Font Size 
This chapter describes how to change the character font size used in the lists of the address books 
and sent/received history. 
 
File 

C:\Program Files\CASIO\MVC\HTML\CSS\mvcCommon.css 
 
Configuration file 

The character font size used in the lists can be changed by freely modifying the “8pt” in the 
configuration file below to any size. 
SELECT 

{ 

 font-size: 8pt;  

} 

 
Note: 
Be sure not to change any other settings. Doing so may cause problems with the screen 
configuration data and prevent the displayed information from functioning properly. 
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